Concurrent Sessions in Windows 7 SP1, service pack version 721

25 posts / 0 new
Last post
Offline
Joined: 17 Nov 2010
Concurrent Sessions in Windows 7 SP1, service pack version 721

Hi,

I had this enabled before the service pack and it worked great. Of course, after applying the service pack, it broke it. I found the guide posted on missing remote and followed the instructions but it appears that this guide was written for an earlier version of the service pack (build 178) and the version I have installed is 721 (according to winver command).

Anyhow, it's not working and I wonder if anyone has got a version of this patch that will work with the current version of the Windows 7 SP1. 

Link to article: http://www.missingremote.com/guide/how-enable-concurrent-sessions-windows-7-service-pack-1-beta

Thanks!

mikinho's picture
Offline
Joined: 19 Mar 2007

David, I'm not at home but when I get there I'll provide a patch for SP1 RC (what I'm using as well)

Offline
Joined: 17 Nov 2010

Thanks a ton! That would be a HUGE help.

Offline
Joined: 22 Nov 2010

Its been a few days since your original post Mikinho and I wasn't sure if maybe you meant you were on vacation and would add it when you got home, of if you were at work and meant later that night.  In either case I also happened upon the article around same time as David, and installed the same SP1 RC only to get the version warning from your patch.  Please let us know when you have had a chance to upload the new patch to the article or this post. 

Thanks

Chris

Offline
Joined: 17 Nov 2010

Any update on this, anyone?

mikinho's picture
Offline
Joined: 19 Mar 2007

I sent via PM to you both.  Was hoping to confirm it worked before we created a new guide for it Smile

Edit: Attached to this post as well.  The 64-bit version only though.  You'll need to manually replace the dll for now.

Offline
Joined: 17 Nov 2010

I'm actually running 32 bit Windows 7. D:

mikinho's picture
Offline
Joined: 19 Mar 2007

DavidHasEdge wrote:

I'm actually running 32 bit Windows 7. D:

Can you send me your dll?  Otherwise it will take me a bit to get a 32-bit virtual setup.

thebasa's picture
Offline
Joined: 10 Oct 2008

file above didn't work for me on Win7 Ult x64 when I rename to termsrv.dll and replace in System32.    

mikinho's picture
Offline
Joined: 19 Mar 2007

What build?

thebasa's picture
Offline
Joined: 10 Oct 2008

7601 v.721 

mikinho's picture
Offline
Joined: 19 Mar 2007

Same version as the attached.  I tested again to ensure it works and it did for me.  I'll go ahead and update the script.

thebasa's picture
Offline
Joined: 10 Oct 2008

We're talking about the attachment above named termsrv_x86-64.dll right?  Why does it say x86?  I've been renaming it to termsrv.dll, takeown on the file in System32, rename, and put new one in there as usual.  I used the old Install.cmd line to set fSingleSessionPerUser to 0, restart service, but when I RDP same user I get the the same session and locks other screen out.  

mikinho's picture
Offline
Joined: 19 Mar 2007

Yes. I am talking about the same file.  It lists x86 since that is the architecture.  x86-64 refers to 64-bit.  x86-32 refers to 32-bit.

I'm in the middle of building a 32-bit virtual and will update the SP1 beta afterwards to update the script.

Offline
Joined: 17 Nov 2010

Here's a copy of my termsrv.dll from 32 bit Windows 7 SP1 RC

I can't guarantee that it's unmodified since I've been trying to resolve this issue.

Note that I added the extension of .ppt so that I could upload the file. Remove that extension and it will again be a .dll

Offline
Joined: 17 Nov 2010

Anyone make any progress yet on this?

thebasa's picture
Offline
Joined: 10 Oct 2008

still unable to use the x64 version above on 7601 v.721.  there was mention of an update to the script. is the new version posted somewhere? 

Offline
Joined: 8 Jan 2011

thebasa wrote:

still unable to use the x64 version above on 7601 v.721.  there was mention of an update to the script. is the new version posted somewhere? 

thebasa wrote:

still unable to use the x64 version above on 7601 v.721.  there was mention of an update to the script. is the new version posted somewhere? 

I'm running Win 7 64-Bit Home Premium Build 7601 (Service Pack 1) v.721 as well.  I tried downloading the updated dll above and placed it in my Win7RDP folder.  I renamed the updated dll to "64_termsrv.dll" and tried running the "Install" command script as an administrator.  

Message is:

"You operating system is not supported. only for Windows 7 Build 7601"

Is this because I'm running Home Premium, or is there another fix coming?

Your support for this concurrent RDP is GREAT...I'm hoping this will work soon.  It's a GREAT feature to be able to use.

thebasa's picture
Offline
Joined: 10 Oct 2008

bump?  

mikinho's picture
Offline
Joined: 19 Mar 2007

The RTM SP1 version for x64 is done, just waiting for 32-bit.  I don't have a copy of the 32-bit SP1 yet.

thebasa's picture
Offline
Joined: 10 Oct 2008

awesome.  is the RTM version on MSDN?  I don't see and service packs under operating systems in the downloads.  Is that only for MVP or some special  subscriptions?

mikinho's picture
Offline
Joined: 19 Mar 2007

It was released to certain testers and partners only.  Some versions leaked but I don't recommend installing them yet.

mikinho's picture
Offline
Joined: 19 Mar 2007

Btw, if you did install the beta or RC.  You will need to uninstall prior to installing RTM.  There is a work-around but I really don't recommend that.

Offline
Joined: 1 Feb 2011

Hi I have installed BETA SP1 Home Premium v721 and i am unable to remove that. Can you help me with the uninstall ?

 

Offline
Joined: 3 Feb 2011

Awesome work guys. I'll be awaiting the RTM SP1 32bit release of termsrv.dll anxiously Smile

Topic locked
Website design by Yammm Software
Powered by Drupal